Latest news:
Sahih al-Bukhari (সহীহ বুখারী) is a free Hadith application for android. This application is advertisement free. Download now https://play.google.com/store/apps/details?id=com.akramhossin.bukharisharif
Task:
To complete this challenge, you must save a line of input from stdin to a variable, print Hello,
World. on a single line, and finally print the value of your variable on a second line.
Input Format:
A single line of text denoting inputString (the variable whose contents must be printed).
Output Format:
Print Hello, World. on the first line, and the contents of inputString on the second line.
Sample Input
Welcome to 30 Days of Code!
Sample Output
Hello, World.
Welcome to 30 Days of Code!
Explanation:
On the first line, we print the string literal Hello, World. On the second line, we print the contents of the inputString variable which, for this sample case,
happens to be Welcome to 30 Days of Code!. If you do not print the variable's contents to stdout, you will not pass the hidden test case.
PHP Solution:
$_fp = fopen("php://stdin", "r");
$inputString = fgets($_fp); // get a line of input from stdin and save it to our variable
// Your first line of output goes here
print("Hello, World.\n");
echo $inputString;
// Write the second line of output
fclose($_fp);
Views : 705